Can't write to transmitter

I have Ignition GW running on a server and an Edge device running Ignition Edge.
I followed all of the following steps in order to allow outbound tag writes:

  • Distributor Settings - User has RW # rights
  • Engine Settings - Disabled “Block Node Commands” & “Block Device Commands”
  • Transmitter Settings - Disabled “Block Commands”
  • Ignition GW Server - Set all Tag Service Security/ Tag Accesses to “readWriteEdit”
  • Ignition Edge - Set all Tag Service Security/ Tag Accesses to “readWriteEdit”

But I am still not able to write to the Edge transmitter’s MQTT tags. I see the following message in the Ignition Edge wrapper:

Any help would be greatly appreciated!

I quickly tested it on my local machine which had al 3 components installed and it worked fine. It seems that it has got something to do with the Edge Ignition GW/Edge Device. Since the write cmd is reaching the Edge device (due to the fact that I am getting errors in the wrapper of Ignition Edge).

Just wanted to add that, but I am still stuck.

It looks like you might be using an older version of Transmission (maybe 4.0.3?). There was a known issue in that version with regard to having an empty ‘Tag Path’ in the Transmission Transmitter configuration. Is this the case in your environment? If so, you have two options. You can upgrade to a new version of Transmission or make sure you have a non-empty value for the Tag Path.

I would also recommend taking a look at this doc that describes the relationship between transmitter configurations and the tag tree in designer: MQTT Transmission Transmitters and Tag Trees - MQTT Modules for Ignition 8.x - Confluence

Thanks a lot Wesley, you are fast and correct, I am using 4.0.3 and by giving it a tag path my issue was solved. I will still change to a newer version once I get a gap.