MQTT Engine v4.0.18 with Ignition Edge v.8.1.28


I spent whole day to configure MQTT Engine Module to work with my Ignition Edge.
The problem is that Edge can read values, but when I am trying to put some value to it, so it sets the tag to 0 value.
Finally I tried to install the older version of MQTT Engine Module, and everything works fine so, that I can read/write values
Now I use MQTT Engine of version 4.0.15 and Ignition Edge version 4.1.28

I tried Ignition version 8.1.32 also, but no luck…

Can anyone tell me if I should set up something in the Ignition Gateway to make it work with version 4.0.18 please

Thanx in Advance

I think it might be best for you to open a support ticket so we can take a look at the logs. Can you send an email to with this same information as well as the logs from the Edge and the system running MQTT Engine? Make sure you are using 4.0.18 so we can see what potential problems may be occurring in the latest version.

Sharing my experience with a similar issue:
Had intermittent MQTT engine connection issues with MQTT Engine version is 4.0.8 + Ignition Edge Version: 8.1.7
It worked well for good year or more and recently engine was disconnecting and connecting constantly I did not get any payloads on any topics.
Solution: Upgrading the MQTT Engine to 4.0.18 fixed the problem.

1 Like

Another instance was Ignition V 8.1.28 + MQTT Engine 4.0.17 was not working for me. I did restore a back up taken from v8.1.13 and restored it in v8.1.28 (not sure if this contributed to the problem). In this setup I was not able to connect to a MQTT broker at all untill I downgraded the Ignition and the Mqtt versions to the following v8.13 + MQTT Engine 4.0.13.

I had a somewhat similar issue , I was upgrading all of our gateways to 8.1.30 (34 of them) #26 was at 8.1.20 / 4.0.6 mqtt engine. I upgraded to 8.1.30 with 4.0.18 like the site says, no luck. could not get the engine to connect to any broker. we restored and tried again , no luck. We tried going back versions of the engine and found that 4.0.13 worked. On this gateway we do have several other modules, I bet there an dependency on one of them. Focusing on that this morning. Hope you find your solution.

If anyone has logs showing the connection failures I’d like to take a look at them after the upgrade. It should denote why the connection is failing. You can either post the appropriate portion of the logs here or open a ticket at