AwsInjectorSettings - Failed to Push

I was having a problem with the AWS module, the DynamoDB option not connecting, as seen in this topic.

After updating the module, the DynamoDB non-connection error was resolved, but the error has now passed to Kinesis and AWS Injector, which are unable to push the data.

java.lang.ClassCastException: class com.cirruslink.ingest.kinesis.KinesisFirehoseIngestService cannot be cast to class com.cirruslink.ingest.kinesis.KinesisIngestService (com.cirruslink.ingest.kinesis.KinesisFirehoseIngestService and com.cirruslink.ingest.kinesis.KinesisIngestService are in unnamed module of loader com.inductiveautomation.ignition.gateway.modules.ModuleClassLoader @2d3fc749)

at com.cirruslink.ingest.kinesis.AbstractKinesisIngestService.push(

at com.cirruslink.ingest.kinesis.AbstractKinesisIngestService.push(



at com.cirruslink.mqtt.common.gateway.agent.AgentEdgeNode$PushDelayTask.doPush(

at com.cirruslink.mqtt.common.gateway.agent.AgentEdgeNode$

at java.base/java.util.TimerThread.mainLoop(Unknown Source)

at java.base/ Source)

What I’ve tried so far.
- Update the Ignition version to 8.1.35 and the AWS Injector module 4.0.20 in my current environment (EC2 Instance) and restart the EC2 instance.
- In a new environment, perform a clean installation of Ignition and install Module 4.0.20

Best regards,

I tried downgrading to version 4.0.18 of the module, the Kinesis error disappeared, but the DynamoDB error returned.